网络ADSL接入及共享技术的实现网络毕业论文

adsl共享  时间:2021-04-21  阅读:()

AD SL接入及共享技术的实现网络毕业论文

目录

1引言

1.普通ADSL Modem双网卡PCWingate之类的代理服务器或防火墙软件

2.普通ADSL Modem +共享器

3带路由功能的ADSL Modem

2网络共享原理

2. 1私有网络地址和公有网络地址

2. 2 NAT原理

3. 1RFC1483 bridged接入方式

3. 2RFC 1577经典IPOA接入方式

3. 3 RFC2364 PPP Over ATM接入方式

3.4 RFC2516 PPPOE接入方式

4开发平台的选择及搭建

4. 1产品定位

4. 2硬件开发平台的选择

4. 3软件开发平台的选择

4.4开发平台搭建简述

1

2在此BSP基础上创建Bootable工程

3编写Alcatel DSP驱动

5. 1 Utopia接口初始化

5. 2加载及初始化函数

5. 3停止及卸载函数

5.4数据发送函数

5. 5中断控制流程

5.6数据接收处理

6. AAL5业务模块的实现

1

2接收 向系统注册业务类型

3

6. 1 vxworks 网络服务子层编写规范

6. 2 AAL5业务Service的实现

1)根据协议类型初始化封装数据、大小等值

2)用muxBind函数绑定接收函数

3)初始化Service网络参数

1 SAR模块收到报文产生中断进入接收中断处理例程

2

3 MUX层询问该报文的协议类型

4 SAR驱动层将reserved中的类型返回给MUX层

5 MUX层根据协议类型将报文提交给相应的Service

6 Service解封装后

1协议栈通过MUX层发送报文

2 MUX层将报文传给预先绑定的Service

3 Service对数据进行封装后

4 MUX层将数据发送到SAR模块相应的PVC接口

5 SAR模块相应的PVC接口发送该报文

6. 3 RFC1483协议报文处理

7增加NAT支持

7. 1 NAT模块主处理流程

7. 2 NAT模块初始化

1) nat_session结构记录每一连接的连接信息

2 nat_interface接口结构

7. 3 NAT模块主要算法

1 session结构数组的初始化

2 新建session

3 查找session

4 删除session

8 设计

正文

论文摘要本文首先阐述网络共享原理分析目前常用的

RFC1483bri dged RFC1483Routed RFC 1577 PPPOA PPPOE等各种AD S L接入协议类型及实现网络共享的方法。

选择Motorola PowerPC 850SAR芯片作为中央处理器搭建基本硬件开发平台 选择WindRiver公司的Tornado2.0作为软件集成开发。参照vxworks5.4操作系统的设备驱动编写规范结合850 CPU的SAR功能初始化 实现SAR层E ND设备驱动。

以RFC 1483协议为例 阐述在不同的ATM复用方式下各种协议数据报文的封装处理方法。参照Vxworks5.4操作系统网络服务子层

的编写规范给出AAL5业务网络服务子层的总体架构及相关算法、流程。在Vxwork s5.4协议栈上实现网络地址转换NAT功能 最后构建出一套简单的AD S L接入共享系统。

1引言

随着AD S L技术的发展 AD S L宽带接入已经不仅仅是一种纯粹的接入技术。家庭局域网的普及 中、小型企业商务的繁荣远程办公模式的引入都呼吁着更、更有效的ADSL接入共享方案的出现。

如今上用于ADSL接入共享的产品非常多如带路由功能的ADSL Modem、 ADSL共享器、 ADSL路由器等等各ADSL厂商根据实际应用的需求在ADSL接入设备的多样性、高效性和灵活性上下功夫进一步扩展了AD S L的应用前景。

实现AD S L接入共享的方式归纳起来有以下三种可以根据实际情况选择最合适的方案。

1.普通ADSL Modem双网卡PCWingate之类的代理服务器或防火墙软件

如图1-1所示双网卡PC安装Wingate之类的代理服务器或防火墙软件一块网卡连接ADSL Modem 另一块连在局域网的HUB上作为其它用户的IP网关。则局域网内的所有微机都可以通过这台主机访问Internet网络。

该方案的优点是无需添加任何设备仅多一张网卡 即可通过软件实现路由功能 同时能够使用软件所带的安全认证、帐户管理、防火墙等一系列功能。比较适合网吧等本就需要一台服务器作为帐户管理的场所。

缺点是 需要占用一台服务器作为数据转发设备较高数据交换的效率较低和服务器的性能有很大关系此外病毒入侵或服务器本身性能不稳定极易造成网络异常。

2.普通ADSL Modem +共享器

所谓共享器其实是一种集成PPPOE、 NAT等功能的简单路由器。图2-2所示的组网方案中共享器取代了前一个方案中双网卡PC的地位。

采用这种方案后可以节省一台服务器以及相关软件的花费较第一种方案来说确实经济很多也不用再担心病毒入侵、服务器不稳定等问题了。很多共享器本身就带多个L AN 口无需再添置HUB或Switch等设备即可供多台微机使用对于家庭局域网或小型办公场所非常合适。

3带路由功能的ADSL Modem

带简单路由器功能的ADSL Modem集成了ADSL接入功能及网络共享技术。如图1-3所示局域网用户仅需将自身的IP网关指向设置在ADSL Modem以太网接口上的IP地址即可实现与外部网络的互连。

由于ADSL接入和路由两种功能集成在同一设备中减少了中间的数据转发环节传输效率会更高一些配置及调试起来也方便很多。此外用一块CPU就可以实现ADSL接入协议及简单路由等软件功能硬件成本降低很多价格比起ADSL Modem +共享器当然更有优势了。

本文将首先介绍网络共享原理然后逐个分析目前常用的各种ADSL接入协议以及实现共享的方式。最后以Motorola 850SAR +Vxworks 5.4为开发平台设计一套带简单路由功能的ADSL接入设备重点阐述ATM SAR层驱动的编写、 AAL5业务、各种接入协议以及带宽共享功能的软件实现。

2网络共享原理

2. 1私有网络地址和公有网络地址

私有地址是指内部网络局域网内部的主机地址而公有网络地址是局域网的外部地址在因特网上的全球唯一的IP地址 。因特网地址分配组织规定以下的三个范围网络地址保留用做私有地址

.0——.255

.0——.255

.0——.255

也就是说这三个范围网络的地址不会在因特网上被分配但可以在一个企业局域网 内部使用。各个企业根据在可预见的将来主机数量的多少来选择一个合适的内部网络地址。不同的企业他们的内部网络地址可以相同。如果一个公司选择上述三个范围之外的其他网段作为内部网络地址则有可能会引起路由的混乱。

2.2 NAT原理

NAT Network Address Tralation网络地址转换是一个IETF标准允许一个机构以一个公有网络地址出现在Internet上。 NAT将每个局域网节点的私有网络地址转换成一个公有网络地址反之亦然。它也可以应用到防火墙技术里把私有地址隐藏起来不被外界发现使外界无法直接访问内部网络设备 同时它还帮助网络可以超越地址的限制合理地安排网络中的公有网络地址和私有网络地址的使用。

NAPT (Network Address and Port Tralation) 网络端口地址转换可以将外部网的公有IP及端口号与内部网络的私有网络IP及端口号相互映射。 通过这种端口重定向方式实现的NAT映射功能可以将来自网络的服务请求映射到内部网络某台微机上。

例如如果公司想以内部网络中的主机A作为对外公开的Web服务器就得告诉NAT设备将任何访问其公网地址80端口的连接重新定向为到内部网络A主机地址的80端口。如下图所示

3 ADSL连接协议概述

UCloud:美国云服务器,洛杉矶节点大促,低至7元起/1个月

ucloud美国云服务器怎么样?ucloud是国内知名云计算品牌服务商家,目前推出全球多地机房的海外云服务器。UCloud主打的优势是海外多机房,目前正在进行的2021全球大促活动参与促销的云服务器机房就多达18个。UCloud新一代旗舰产品快杰云服务器已上线洛杉矶节点,覆盖北美和亚太地区,火热促销中, 首月低至7元,轻松体验具备优秀性能与极高性价比的快杰云服务器。点击进入:ucloud美国洛杉矶...

VPSMS:53元/月KVM-512MB/15G SSD/1TB/洛杉矶CN2 GIA

VPSMS最近在做两周年活动,加上双十一也不久了,商家针对美国洛杉矶CN2 GIA线路VPS主机提供月付6.8折,季付6.2折优惠码,同时活动期间充值800元送150元。这是一家由港人和国人合资开办的VPS主机商,提供基于KVM架构的VPS主机,美国洛杉矶安畅的机器,线路方面电信联通CN2 GIA,移动直连,国内访问速度不错。下面分享几款VPS主机配置信息。CPU:1core内存:512MB硬盘:...

小欢互联19元/月起, 即日起至10月底 美国CERA 促销活动 美国/香港八折

小欢互联成立于2019年10月,主打海外高性价比云服务器、CDN和虚拟主机服务。近期上线了自营美国CERA机房高速VPS,进行促销活动,为客户奉上美国/香港八折优惠码:Xxc1mtLB优惠码适用于美国CERA一区/二区以及香港一区/二区优惠时间:即日起至10月底优惠码可无限次使用,且续费同价!官网:https://idc.xh-ws.com购买地址:美国CERA一区:https://idc.xh-...

adsl共享为你推荐
杭州市西湖区翠苑第四幼儿园智慧校园采购项目支持ipadcss3圆角怎样用css实现圆角矩形?ipad连不上wifi苹果ipad突然连不上网了,是怎么回事?网络是好的,手机能上网。windows键是哪个Win键是什么?windows键是哪个Windows键是哪个键啊?win7如何关闭445端口如何关闭445端口,禁用smb协议重庆电信宽带管家中国电信10000管家用着怎么样啊??google图片搜索如何用google搜索空间照片icloudiphone苹果6显示已停用请连接itunes什么意思
国内vps 免费com域名申请 视频存储服务器 国内永久免费云服务器 unsplash 服务器架设 cpanel空间 数字域名 老左正传 cdn加速是什么 hktv 登陆空间 沈阳主机托管 浙江服务器 如何登陆阿里云邮箱 大化网 闪讯网 googlevoice 沈阳idc 腾讯云平台 更多