接入ADSL接入及共享技术的实现(一)

adsl共享  时间:2021-04-21  阅读:()

ADSL接入及共享技术的实现一

目录

1引言

1.普通ADSL Modem双网卡PCWingate之类的代理服务器或防火墙软件

2.普通ADSL Modem +共享器

3带路由功能的ADSL Modem

2网络共享原理

2. 1私有网络地址和公有网络地址

2. 2 NAT原理

3. 1 RFC1483 bridged接入方式

3. 2 RFC1577经典IPOA接入方式

3. 3 RFC2364 PPP Over ATM接入方式

3.4 RFC2516 PPPOE接入方式

4开发平台的选择及搭建

4. 1产品定位

4. 2硬件开发平台的选择

4. 3软件开发平台的选择

4.4开发平台搭建简述

1

2在此BSP基础上创建Bootable工程

3编写Alcatel DSP驱动

5. 2 加载及初始化函数

5. 3停止及卸载函数

5.4数据发送函数

5. 5中断控制流程

5.6数据接收处理

6. AAL5业务模块的实现

1

2接收 向系统注册业务类型

3

6. 1 vxworks 网络服务子层编写规范

6. 2 AAL5业务Service的实现

1)根据协议类型初始化封装数据、大小等值

2)用muxBind函数绑定接收函数

3)初始化Service网络参数

正文

论文关键词 网络共享AAL5业务ADS L接入协议NAT协议ADSL路由功能

论文摘要本文首先阐述网络共享原理分析目前常用的

RFC1483bri dged RFC1483Routed RFC 1577 PPPOA PPPOE等各种AD S L接入协议类型及实现网络共享的方法。

选择Motorola PowerPC 850SAR芯片作为中央处理器搭建基本硬件开发平台 选择WindRiver公司的Tornado2.0作为软件集成开发环境。参照vxworks5.4操作系统的设备驱动编写规范结合850C PU的SAR功能初始化 实现SAR层END设备驱动。

以RFC 1483协议为例 阐述在不同的ATM复用方式下各种协议数据报文的封装处理方法。参照Vxworks5.4操作系统网络服务子层的编写规范给出AAL5业务网络服务子层的总体架构及相关算法、流程。在Vxwork s5.4协议栈上实现网络地址转换NAT功能 最后构建出一套简单的AD S L接入共享系统。

1引言

随着AD S L技术的发展 AD S L宽带接入已经不仅仅是一种纯粹的接入技术。家庭局域网的普及 中、小型企业电子商务的繁荣远程办公模式的引入都呼吁着更经济、更有效的ADS L接入共享方案的出现。

如今市场上用于AD S L接入共享的产品非常多如带路由功能的ADSL Modem、 ADSL共享器、 ADSL路由器等等各ADSL厂商根据实际应用的需求在ADSL接入设备的多样性、高效性和灵活性上下功夫进一步扩展了AD S L的应用前景。

实现AD S L接入共享的方式归纳起来有以下三种可以根据实际情况选择最合适的方案。

1.普通ADSL Modem双网卡PCWingate之类的代理服务器或防火墙软件

如图1-1所示双网卡PC安装Wingate之类的代理服务器或防火墙软件一块网卡连接ADSL Modem 另一块连在局域网的HUB上作为其它用户的IP网关。则局域网内的所有微机都可以通过这台主机访问Internet网络。

图1-1 双网卡PC+ADSL Modem接入示意图

该方案的优点是无需添加任何设备仅多一张网卡 即可通过软件实现路由功能 同时能够使用管理软件所带的安全认证、帐户管理、防火墙等一系列功能。 比较适合网吧等本就需要一台服务器作为帐户管理的场所。

缺点是 需要占用一台服务器作为数据转发设备成本较高数据交换的效率较低和服务器的性能有很大关系此外病毒入侵或服务器本身性能不稳定极易造成网络异常。

2.普通ADSL Modem +共享器

所谓共享器其实是一种集成PPPOE、 NAT等功能的简单路由器。图2-2所示的组网方案中共享器取代了前一个方案中双网卡PC的地位。

采用这种方案后可以节省一台服务器以及相关软件的花费较第一种方案来说确实经济很多也不用再担心病毒入侵、服务器不稳定等问题了。很多共享器本身就带多个L AN 口无需再添置HUB或Switch等设备即可供多台微机使用对于家庭局域网或小型办公场所非常合适。

图1-2共享器+ ADSL Modem接入示意图

3带路由功能的ADSL Modem

带简单路由器功能的ADSL Modem集成了ADSL接入功能及网络共享技术。如图1-3所示局域网用户仅需将自身的IP网关指向设置在ADSL Modem以太网接口上的IP地址 即可实现与外部网络的互连。

由于ADSL接入和路由两种功能集成在同一设备中减少了中间的数据转发环节传输效率会更高一些配置及调试起来也方便很多。此外用一块CPU就可以实现ADSL接入协议及简单路由等软件功能硬件成本降低很多价格比起ADSL Modem +共享器当然更有优势了。

图1-3带简单路由功能的ADSL Modem接入示意图

本文将首先介绍网络共享原理然后逐个分析目前常用的各种ADSL接入协议以及实现共享的方式。最后以Motorola 850SAR +Vxworks 5.4为开发平台设计一套带简单路由功能的ADSL接入设

备重点阐述ATM SAR层驱动的编写、 AAL5业务、各种接入协议以及带宽共享功能的软件实现。

2网络共享原理

2. 1私有网络地址和公有网络地址

私有地址是指内部网络局域网内部的主机地址而公有网络地址是局域网的外部地址在因特网上的全球唯一的IP地址 。因特网地址分配组织规定以下的三个范围网络地址保留用做私有地址

.0——.255

.0——.255

.0——.255

也就是说这三个范围网络的地址不会在因特网上被分配但可以在一个企业局域网 内部使用。各个企业根据在可预见的将来主机数量的多少来选择一个合适的内部网络地址。不同的企业他们的内部网络地址可以相同。如果一个公司选择上述三个范围之外的其他网段作为内部网络地址则有可能会引起路由的混乱。

2.2 NAT原理

NAT Network Address Tralation网络地址转换是一个IETF标准允许一个机构以一个公有网络地址出现在Internet上。 NAT将

每个局域网节点的私有网络地址转换成一个公有网络地址反之亦然。它也可以应用到防火墙技术里把私有地址隐藏起来不被外界发现使外界无法直接访问内部网络设备 同时它还帮助网络可以超越地址的限制合理地安排网络中的公有网络地址和私有网络地址的使用。

NAPT (Network Address and Port Tralation) 网络端口地址转换可以将外部网的公有IP及端口号与内部网络的私有网络IP及端口号相互映射。 通过这种端口重定向方式实现的NAT映射功能可以将来自公共网络的服务请求映射到内部网络某台微机上。

例如如果公司想以内部网络中的主机A作为对外公开的Web服务器就得告诉NAT设备将任何访问其公网地址80端口的连接重新定向为到内部网络A主机地址的80端口。如下图所示

图2-1 NAT端口映射应用示意图

3 ADSL连接协议概述

3. 1 RFC1483 bridged接入方式

RFC 1483标准的制定是为了实现多种协议数据包在ATM的AAL 5层的封装传送。在协议模型上 RFC1483-bridged方式在数据链路层对MAC帧进行LLCNAP或VCMUX的封装 以此来指明上层所应用的协议类型 因此可以适用于网络层上的多协议传送。在形式上它仿真了

以太网的桥接功能相当于将用户侧的终端设备直接挂接在网络侧的网桥设备上。

由于ADSL接入设备配置为桥连接方式理论上来说设备后可以接多台配置为公网IP地址的微机这些微机都可以通过网关直接接入Internet网络中。但实际上可分配的公有IP地址并不多很多服务提供商限制了每根线上可分配的IP个数 因此只有将IP地址设在ADSL接入设备的WAN端 然后通过NAT的方式来共享有限的IP资源这就是目前较为常见的1483bridged+NAT接入方式又称为桥路由方式其接入模型如图3-1所示。

图3-1 1483bridgedNAT接入示意图

3.2 RFC1577经典IPOA接入方式

严格的说 RFC 1577并非一种接入标准它规定了在A TM的AA L 5上使用的地址解析机制是对RFC1483 Routed接入方式在ATMARP实现细节的补充。在协议模型上 RFC 1577不再转发类似A RP协议的各种以太网报文 而是通过和网络指定的ARP服务器交互ATMARP信息获得下一跳IP地址所对应的ATM地址然后采用RFC 1483LLCNAP或基于VC的复用方式对Rout ed报文进行封装处理。

RFC1577一般用于需要静态IP的商业用户 和RFC 1483br idged方式一样可以采用带NAT功能的设备实现多台微机共享带宽。

3.3 RFC2364 PPP Over ATM接入方式

Hostodo(年付12美元)斯波坎VPS六六折,美国西海岸机房

Hostodo是一家成立于2014年的国外VPS主机商,现在主要提供基于KVM架构的VPS主机,美国三个地区机房:拉斯维加斯、迈阿密和斯波坎,采用NVMe或者SSD磁盘,支持支付宝、PayPal、加密货币等付款方式。商家最近对于上架不久的斯波坎机房SSD硬盘VPS主机提供66折优惠码,适用于1GB或者以上内存套餐年付,最低每年12美元起。下面列出几款套餐配置信息。CPU:1core内存:256MB...

BeerVM1GB内存/VDSps端口1GB,350元/月

beervm是一家国人商家,主要提供国内KVM VPS,有河南移动、广州移动等。现在预售湖南长沙联通vds,性价比高。湖南长沙vps(长沙vds),1GB内存/7GB SSD空间/10TB流量/1Gbps端口/独立IP/KVM,350元/月,有需要的可以关注一下。Beervm长沙联通vps套餐:长沙联通1G青春版(预售)长沙联通3G标准版(预售)长沙联通3G(预售)vCPU:1vCPU:2vCPU...

wordpress外贸集团企业主题 wordpress高级推广外贸主题

wordpress外贸集团企业主题,wordpress通用跨屏外贸企业响应式布局设计,内置更完善的外贸企业网站优化推广功能,完善的企业产品营销展示 + 高效后台自定义设置。wordpress高级推广外贸主题,采用标准的HTML5+CSS3语言开发,兼容当下的各种主流浏览器,根据用户行为以及设备环境(系统平台、屏幕尺寸、屏幕定向等)进行自适应显示; 完美实现一套主题程序支持全部终端设备,保证网站在各...

adsl共享为你推荐
上海工程技术大学支出127技术参数及要求:杭州市西湖区翠苑第四幼儿园智慧校园采购项目win10关闭445端口在win10 如何关闭445端口的最新相关信息联通版iphone4s怎么区分iphone4s电信版和联通版google图片搜索谁能教我怎么在手机用google的图片搜索啊!!!chromeframechrome需要frame吗firefoxflash插件火狐浏览器怎么安装flash迅雷下载速度为什么现在迅雷下载的速度比原来慢得多?
godaddy域名注册 老左 dreamhost 美国便宜货网站 e蜗牛 gg广告 蜗牛魔方 促正网秒杀 美国十次啦服务器 炎黄盛世 稳定免费空间 闪讯官网 备案空间 英雄联盟台服官网 net空间 数据库空间 电信网络测速器 工信部网站备案查询 lamp架构 免费网络空间 更多