通过更换数据库版本解决无法导入数据库兼容编码问题

数据库  时间:2021-03-20  阅读:()

这个问题是昨天晚上有在帮助一个网友迁移网站服务器的时候遇到的。这个同学需要将一个网站迁移到一个新的服务器中,这不他正常的安装WEB环境,包括Nginx、mysql、PHP等等,但是他告诉在迁移导入数据库的时候使用的是phpmyadmin,但是在导入的时候有报错。出现"COLLATION 'utf8_general_ci' is not valid for CHARACTER SET 'utf8mb4'"提示。

通过更换数据库版本解决无法导入数据库兼容编码问题

实际上这个问题,以前也有遇到过,我也有在之前的文章中记录。

1、解决WordPress导入数据库"Unknown collation: 'utf8mb4_unicode_ci"错误

2、解决WordPress数据库导入阿里云主机出现编码报错问题

我开始建议他看下文章,然后将数据库解压之后用记事本打开后将一些字符替换。这里我知道是因为数据库版本兼容问题,但是我让他自己确认过,原来是MYSQL5.5,目前还是MYSQL5.5,我估计他记错的,这个版本应该是需要高版本的数据库。

替换字符编码是可以解决问题,但是我先麻烦,就直接在他的服务器环境中卸载MYSQL数据库。然后重新安装MYSQL5.7版本。然后再通过phpmyadmin导入数据库。

不过我在导入的时候发现速度很慢,而且看到他数据库有几十M,所以我放弃这样的导入,直接采用mysql命令导入数据库。问题解决。

为你推荐
磐石云-6.5折优惠,返大额现金,香港CN2-GIA 福州BGP高防云记录如何在Ubuntu 20.04系统中安装xrdp实现桌面RDPUCloud 全球31个机房云服务器大促 个人用户低至年77元DogYun(狗云)春节动态云7折,经典云8折,充100送10元,香港VPS年付199元起CloudCone春节促销:洛杉矶KVM年付7.5美元起BUDGETVM-美国日本物理机,5折优惠,$40/月,1Gbps不限流量,E3-1231v3/16g内存/1T硬盘,1800G高防!-789spinservers春节促销:100M-10Gbps不限流量服务器119美元起,圣何塞机房RAKsmart开年活动:E3服务器秒杀$30/月起,VPS全场7折,爆款VPS月付1.99美元起NexusBytes – 牛年开春全场VPS主机八折 美国/德国/日本等多机房SpartanHost斯巴达商家西雅图VPS主机三网联通线路方案
时序数据库 数据库特点 人才数据库证书查询 数据库建表 人民日报图文数据库 数据库英文 数据库三范式 数据库的增删改查 什么是网络数据库 mongodb数据库 数据库语言 创建数据库的sql语句 数据库避免了一切数据的重复 mysql数据库基础知识 数据库系统主要包括 分布式数据库 数据库连接池 数据库日志文件 数据库修改密码 数据库名 更多