会话singlehop

singlehop  时间:2021-01-03  阅读:()

i目录1BFD·1-11.
1BFD简介1-11.
1.
1单跳检测和多跳检测1-11.
1.
2BFD会话的工作方式和检测模式1-11.
1.
3BFD支持的应用·1-21.
1.
4协议规范1-21.
2BFD配置限制和指导·1-31.
3配置echo报文方式的BFD会话1-31.
4配置控制报文方式的BFD会话·1-41.
4.
1BFD会话建立方式·1-41.
4.
2配置限制和指导1-41.
4.
3创建静态BFD会话1-41.
4.
4配置单跳检测的BFD会话参数·1-61.
4.
5配置多跳检测的BFD会话参数·1-71.
4.
6配置BFD回声功能1-71.
4.
7配置接口状态与BFD联动1-81.
5配置BFD模板·1-91.
6开启告警功能·1-101.
7BFD显示和维护1-101-11BFD1.
1BFD简介BFD(BidirectionalForwardingDetection,双向转发检测)是一个通用的、标准化的、介质无关和协议无关的快速故障检测机制,用于检测转发路径的连通状况,保证设备之间能够快速检测到通信故障,以便能够及时采取措施,保证业务持续运行.
BFD可以为各种上层协议(如路由协议)快速检测两台设备间双向转发路径的故障.
上层协议通常采用Hello报文机制检测故障,所需时间为秒级,而BFD可以提供毫秒级检测.
1.
1.
1单跳检测和多跳检测BFD可以用来进行单跳和多跳检测:单跳检测:是指对两个直连设备进行IP连通性检测,这里所说的"单跳"是IP的一跳.
多跳检测:BFD可以检测两个设备间任意路径的链路情况,这些路径可能跨越很多跳.
1.
1.
2BFD会话的工作方式和检测模式BFD会话通过echo报文和控制报文实现.
1.
echo报文方式echo报文封装在UDP报文中传送,其UDP目的端口号为3785.
本端发送echo报文建立BFD会话,对链路进行检测.
对端不建立BFD会话,只需把收到的echo报文转发回本端.
如果在检测时间内没有收到对端转发回的echo报文,则认为会话down.
当BFD会话工作于echo报文方式时,仅在MPLSTE隧道的场景中支持多跳检测,其他应用的BFD会话仅支持单跳检测,两种应用均不受检测模式的控制.
2.
控制报文方式控制报文封装在UDP报文中传送,对于单跳检测其UDP目的端口号为3784,对于多跳检测其UDP目的端口号为4784.
链路两端的设备通过控制报文中携带的参数(会话标识符、期望的收发报文最小时间间隔、本端BFD会话状态等)协商建立BFD会话.
BFD会话建立前有两种模式:主动模式和被动模式.
主动模式:在建立会话前不管是否收到对端发来的BFD控制报文,都会主动发送BFD控制报文;被动模式:在建立会话前不会主动发送BFD控制报文,直到收到对端发送来的控制报文.
通信双方至少要有一方运行在主动模式才能成功建立起BFD会话.
BFD会话建立后有两种模式:异步模式和查询模式.
异步模式:设备周期性发送BFD控制报文,如果在检测时间内没有收到对端发送的BFD控制报文,则认为会话down.
查询模式:本端的BFD会话工作在查询模式时,本端设备会向对端发送D比特位置1的BFD控制报文,对端(缺省为异步模式)收到该报文后将停止周期性发送BFD控制报文.
这种情1-2况下,仅对本端到对端的链路进行检测,即当对端设备在检测时间内未收到BFD控制报文时,则认为链路故障,将BFD会话状态置为down.
如果通信双方的BFD会话均工作在查询模式,则双方都停止周期性发送BFD控制报文.
这种情况下,系统将通过其他与BFD无关的机制对链路进行检测(比如Hello报文机制、硬件检测机制等).
当系统中的BFD会话数量较多时,采用查询模式可防止周期性发送BFD控制报文的开销对系统的正常运行造成影响.
1.
1.
3BFD支持的应用表1-1BFD支持的应用应用参见信息静态路由IS-ISOSPFRIPBGPIP快速重路由"三层技术-IP路由配置指导"IPv6静态路由OSPFv3"三层技术-IP路由配置指导"PIM"IP组播配置指导"RSVPMPLSMPLSL3VPNMPLSOAM"MPLS配置指导"Track"可靠性配置指导"以太网链路聚合"二层技术-以太网交换配置指导"1.
1.
4协议规范与BFD相关的协议规范有:RFC5880:BidirectionalForwardingDetection(BFD)RFC5881:BidirectionalForwardingDetection(BFD)forIPv4andIPv6(SingleHop)RFC5882:GenericApplicationofBidirectionalForwardingDetection(BFD)RFC5883:BidirectionalForwardingDetection(BFD)forMultihopPathsRFC5884:BidirectionalForwardingDetection(BFD)forMPLSLabelSwitchedPaths(LSPs)RFC5885:BidirectionalForwardingDetection(BFD)forthePseudowireVirtualCircuitConnectivityVerification(VCCV)RFC7130:BidirectionalForwardingDetection(BFD)onLinkAggregationGroup(LAG)Interfaces1-31.
2BFD配置限制和指导缺省BFD运行版本1,同时兼容版本0.
不能通过命令行配置修改为版本0,当对端设备运行版本0会话时,本端自动会切换到版本0.
BFD会话建立后,可以动态协商BFD的相关参数(例如最小发送间隔、最小接收间隔、初始模式、报文认证等),两端协议通过发送相应的协商报文后采用新的参数,不影响会话的当前状态.

香港云服务器 1核 256M 19.9元/月 Mineserver Ltd

Mineserver(ASN142586|UK CompanyNumber 1351696),已经成立一年半。主营香港日本机房的VPS、物理服务器业务。Telegram群组: @mineserver1 | Discord群组: https://discord.gg/MTB8ww9GEA7折循环优惠:JP30(JPCN2宣布产品可以使用)8折循环优惠:CMI20(仅1024M以上套餐可以使用)9折循...

新注册NameCheap账户几天后无法登录原因及解决办法

中午的时候有网友联系提到自己前几天看到Namecheap商家开学季促销活动期间有域名促销活动的,于是就信注册NC账户注册域名的。但是今天登录居然无法登录,这个问题比较困恼是不是商家跑路等问题。Namecheap商家跑路的可能性不大,前几天我还在他们家转移域名的。这里简单的记录我帮助他解决如何重新登录Namecheap商家的问题。1、检查邮件让他检查邮件是不是有官方的邮件提示。比如我们新注册账户是需...

Hostigger不限流量VPS年20美元

Hostigger 主机商在前面的文章中也有介绍过几次,这个商家运营时间是有一些年份,只不过在我们圈内好像之前出现的次数不多。最近这段时间商家有提供不限流量的VPS主机,逐渐的慢慢被人认识到。在前面的介绍到他们提供的机房还是比较多的,比如土耳其、美国等。今天看到Hostigger 商家居然改动挺大的,原来蛮好的域名居然这次连带官方域名都更换掉去掉一个G(Hostiger )。估摸着这个域名也是之前...

singlehop为你推荐
域名空间注册网站域名空间注册独立ip空间如何设置独立IP加到现有空间域名注册申请域名申请有什么要求免费美国主机哪里有免费不限流量的国外主机已备案域名查询如何查询已备案域名是不是万网/阿里云接入的备案成都虚拟空间五星网络隶属于成都冠一科技有限公司,虚拟空间购买了不到一个月不能访问2次,质量真差啊!asp网站空间谁有能申请免费的ASP空间网站?北京网站空间求永久免费的网站服务器!香港虚拟主机香港的虚拟主机好不好,如何选择虚拟主机?万网虚拟主机万网免费虚拟主机和收费虚拟主机有什么区别
shopex虚拟主机 高防服务器租用 科迈动态域名 国外服务器 紫田 20g硬盘 2017年黑色星期五 国内php空间 ca4249 免费个人空间申请 工作站服务器 php空间推荐 ntfs格式分区 美国网站服务器 闪讯官网 腾讯总部在哪 免费邮件服务器 ssl加速 小夜博客 xshell5注册码 更多