实验解压缩软件哪个好

解压缩软件哪个好  时间:2021-01-25  阅读:()

第一部分实验与课程设计l第1章实验平台介绍l第2章全加器实验l第3章运算器实验l第4章存储器实验l第5章总线与微命令实验l第6章累加器实验l第7章程序计数器实验l第8章微程序控制器实验l第9章简单模型机实验l第10章微程序设计实验l第11章模型机课程设计1计算机组成原理实验教程2第1章实验平台介绍本书使用的实验平台为"多思计算机组成原理网络虚拟实验系统".
此系统由湘南学院张雯雰老师设计开发,属于开源软件,采用GPL开源许可协议.
本系统基于JavaScript、VML等浏览器客户端技术,系统结构简单,无需安装任何插件,既能以B/S模式运行,也可不加修改直接以单机方式运行,并且非常易于整合到其他综合性网络实验平台中.
本系统设计、实现了多个经典实验,实验透明度较高.
例如对于关键的微程序控制器实验,并没有屏蔽微程序控制器的内部电路将其抽象、封装为一个组件,而是给出了一个由微地址生成逻辑、微地址寄存器、微程序存储器和时序发生器组成的具体电路,便于实验者了解控制器的工作原理,理解微指令中顺序控制部分的作用,为模型机与微程序设计打下基础.
本系统具有高度的可扩展性,支持电路设计,便于设计性实验的开展.
1.
1系统安装1.
运行环境"多思计算机组成原理网络虚拟实验系统"有两种运行模式,即单机模式和B/S模式,其运行环境分别为:(1)单机模式:Windows7操作系统,IE10.
0以上版本浏览器.
(2)B/S模式:服务器安装Windows7操作系统和IIS服务,客户机安装Windows7操作系统和IE10.
0以上版本浏览器.
2.
安装步骤"多思计算机组成原理网络虚拟实验系统"属于绿色软件,安装非常简单.

在单机模式下,将程序压缩包解压,将解压后的文件夹复制到安装目的位置即可完成安装,双击文件夹里的index.
html文件就可打开虚拟实验室主界面.
B/S模式时,可按以下步骤安装和使用:(1)设置服务器的IP地址.
(2)将程序压缩包解压,在IIS中将解压后的程序文件夹配置为可访问的网站.

(3)在客户端浏览器的地址栏中输入服务器IP地址即可打开虚拟实验系统主界面.

3.
主界面虚拟实验系统主界面包括菜单栏、工具栏、工具箱和工作区四个部分,如图1.
1所示.
其中,工具箱可以用鼠标拖动以改变其位置和大小,单击工具栏上的按钮可以隐藏或显示工具箱.
注意:在单机运行模式下打开主界面时,屏幕下方会出现一个如图1.
2所示的提示框,这是IE浏览器的安全措施,此时应该单击右边的"允许阻止的内容"按钮,否则程序不能正常运行.

B/S模式下没有这个问题.
设置IE浏览器的高级选项可以避免出现此对话框,方法为:打开"Internet选项"对话框,在"高级"选项卡里勾选"允许活动内容在'我的电脑'的文件中运行".
第一部分实验与课程设计3图1.
1多思虚拟实验系统主界面图1.
2限制脚本运行提示框1.
2电路绘制1.
实验组件组件生成:要在工作区生成需要的实验组件,只需将组件从工具箱拖到工作区即可.
芯片引脚有4种颜色,表示4类不同的引脚:黑色为默认已经接好、不需要再连接的引脚,如接地、接电源的引脚;绿色为输出引脚;蓝色为输入引脚;紫色为输入/输出引脚,如图1.
3所示.
组件移动:在组件中部非引脚区域按下鼠标并拖拽,可以移动组件,此组件的连接线会自动重新绘制以适应新位置.
组件删除:在组件中部非引脚区域右击鼠标,会弹出一个对话框询问是否要删除组件及其连接线,单击"确定"后即删除.
工具箱中的实验设备分为四类:数字功能器件、逻辑门电路、基本元件和虚拟组件.
其中,虚拟组件是屏蔽了内部电路,通过抽象、封装而成的组件,现实中没有真正的芯片与之对应,如EPROM2716C3是将三片EPROM2716进行位扩展组成的24位存储器组件.
查看芯片各引脚的值:双击芯片,在弹出的对话框中可以看到当前各引脚的值.
0表示低电平,1表示高电平,2表示不确定或其他值.
2.
连接线绘制连接线:当鼠标移动到引脚上方,使得引脚背景色变为绿色时,表示已进入引脚拉线区域,此时可以拖拽鼠标引出一根连接线,到达目标引脚的拉线区域时再放开鼠标,虚拟实验系统会自动在2个引脚之间生成一根连接线,如图1.
4所示.
菜单栏工具栏工具箱工作区计算机组成原理实验教程4图1.
3组件生成图1.
4连接线生成删除连接线:当鼠标移动到一根连接线上方时,此线会以粗红色线条表示,这时右击鼠标可以删除此连线.
1.
3文件操作1.
新建单击工具栏上的按钮,或者单击"文件"菜单上的"新建"选项,都可以执行新建操作.
刚打开的主界面默认处于新建文件状态,可以直接在工作区新建电路图.
在工作区已经有电路图的情况下执行新建,会自动删除原有电路,清空工作区.
第一部分实验与课程设计52.
打开单击"文件"菜单上的"打开"选项,可以打开已经绘制好的电路图文件.
在弹出的页面中单击"浏览",选择电路文件打开即可.
3.
保存单击"文件"菜单上的"保存"选项,可以保存当前工作区电路图.
在弹出的页面中单击"保存"或者"另存为",选择存放路径即可,如图1.
5所示.
图1.
5电路图文件的保存1.
4电路运行1.
开电源单击工具栏上的电源按钮,或者单击菜单上的"开电源"选项,都可以打开电源,电路开始运行.
注意:当电源打开时,不能在电路上增删组件,即不能带电拔插器件,否则会出现电路运行错误.
如需增删组件,要先关闭电源然后进行相关操作.
2.
关电源当工具栏上的电源按钮为打开时,单击此按钮,或者单击菜单上的"关电源"选项,都可以关闭电源.
3.
重启单击工具栏上的按钮,或者单击"运行"菜单上的"重启"选项,都可以重启实验电路.
1.
5使用工具1.
存储器芯片设置单击"工具"菜单上的"存储器芯片设置"选项,系统会打开存储器读写网页,如图1.
6计算机组成原理实验教程6所示.
在"请选择欲读写的存储器芯片"栏中选择需要修改的芯片(只能读写在工作区中的存储芯片).
如果选择"RAM6116CP0",此芯片中存储的数据会在下方矩形框中显示,并且可以修改后重新写入.
图1.
6存储器芯片设置2.
连接线颜色选择单击"工具"菜单上的"连接线颜色选择"选项,系统会在打开的网页上显示如图1.
7所示的界面.
图1.
7连接线颜色选择在颜色选择区域选择好颜色后,单击"Enter"按钮即可保存修改.
3.
时钟周期设置单击"工具"菜单上的"时钟周期设置"选项,会弹出如图1.
8所示的对话框.
此时拖动滑块就可以设置时钟周期的大小.
第一部分实验与课程设计7图1.
8时钟周期设置1.
6实验指导1.
实验指导书单击"实验指导"菜单上的"实验指导书"选项,可以查看实验指导书以及各实验的简介.

2.
实验器件资料单击"实验指导"菜单上的"实验器件资料"选项,可查看各芯片的数据手册.

VinaHost,越南vps,国内延时100MS;不限流量100Mbps

vinahost怎么样?vinahost是一家越南的主机商家,至今已经成13年了,企业运营,老牌商家,销售VPS、虚拟主机、域名、邮箱、独立服务器等,机房全部在越南,有Viettle和VNPT两个机房,其中VNPT机房中三网直连国内的机房,他家的产品优势就是100Mbps不限流量。目前,VinaHost商家发布了新的优惠,购买虚拟主机、邮箱、云服务器、VPS超过三个月都有赠送相应的时长,最高送半年...

提速啦(69元起)香港大带宽CN2+BGP独享云服务器

香港大带宽服务器香港大带宽云服务器目前市场上可以选择的商家十分少,这次给大家推荐的是我们的老便宜提速啦的香港大带宽云服务器,默认通用BGP线路(即CN2+BGP)是由三网直连线路 中国电信骨干网以及HGC、NTT、PCCW等国际线路混合而成的高品质带宽(精品带宽)线路,可有效覆盖全球200多个国家和地区。(适用于绝大部分应用场景,适合国内外访客访问,域名无需备案)提速啦官网链接:点击进入香港Cer...

Pia云服务商春节6.66折 美国洛杉矶/中国香港/俄罗斯和深圳机房

Pia云这个商家的云服务器在前面也有介绍过几次,从价格上确实比较便宜。我们可以看到最低云服务器低至月付20元,服务器均采用KVM虚拟架构技术,数据中心包括美国洛杉矶、中国香港、俄罗斯和深圳地区,这次春节活动商家的活动力度比较大推出出全场6.66折,如果我们有需要可以体验。初次体验的记得月付方案,如果合适再续约。pia云春节活动优惠券:piayun-2022 Pia云服务商官方网站我们一起看看这次活...

解压缩软件哪个好为你推荐
视频制作软件哪个好免费的视频剪辑软件用哪个好?法兰绒和珊瑚绒哪个好法兰绒和珊瑚绒哪个好被套好尼康和佳能单反哪个好入门的单反相机 佳能和尼康哪个好?播放器哪个好什么播放器好用牡丹江教育云空间登录我想知道校园云空间是用什么账号登录的?qq空间登录器QQ空间校友网页自动登陆器qq空间登录网址开通QZONeqq空间登录网站QQ空间打开需要输入用户名和密码,下面是正在连接一个网址和领域网址dns服务器地址dns服务器地址便宜的儿童手机请问哪有价格便宜又安全低辐射的儿童手机?
顶级域名 com域名价格 美国vps评测 怎么申请域名 国外空间服务商 国外php空间 商务主机 绍兴高防 anylink cdn联盟 免费全能主机 web服务器安全 网页提速 东莞服务器托管 石家庄服务器托管 可外链的相册 腾讯服务器 服务器是什么意思 hosts文件修改 服务器操作系统 更多