disrupt免费dns
免费dns 时间:2021-04-20 阅读:(
)
1464XLAT:BreakingFreeofIPv4Cameron.
Byrne@T-Mobile.
comAPRICOT2014BackgroundT-MobileUSisaGSM/UMTS/LTEproviderintheUSAwith45+MillionsubscribersIn2008,T-MobilelaunchedthefirstAndroidphone.
Thisdramaticallychangedthemobiledatadynamics–moredevices,connectedforalongertime,allneedingIPaddressesT-MobileembracedtheconceptofIPv6-only,sincedual-stackrequiredIPv4thatwasnotavailableNAT64/DNS64wasagoodsolutionthatdidnotrequireIPv4oneachclient,butsomeapplicationsfailedtoworkonIPv6-onlynetworks.
ItisnotacceptabletobreakSkypeorNetflix,applicationsthatrequireIPv4T-Mobile,inpartnershipwithNECandJPIX,documented464XLATintheIETFasRFC6877toovercomethelimitationsofNAT64byaddingaNAT46intotheclient(CLAT)Android4.
3introducedsupportfor464XLATinOctober20132ResultsAreImportantT-MobileUSlaunched5Androidphoneswith464XLATasthedefaultinthelast5months,allAndroid4.
3+phoneswillbe464XLATinthefutureatT-MobileUS3.
6millionuniqueIPv6subscribersinthefirst5monthsareactiveonthenetworkhttp://www.
worldipv6launch.
org/measurements/measurementsshow15.
76%ofallT-MobileconnectionsarenowIPv6,asofFebruary21,2014Over50%ofIPv6-usertrafficisend-to-endIPv6(notranslationneeded)Thissavesmoneyandmakesthenetworksimpler315.
76ofT-MobileUSConnectionsuse464XLAT4Default464XLATPhonesatT-MobileUS5SamsungNote3Google/LGNexus5SamsungMega464XLATPhones6SonyZ1sGalaxyLight464XLATallowsforfullfunctionalityonIPv6-onlynetworksDual-stackdoesnotsolvetheIPv4numberscarcityissueIPv6-only+NAT64/DNS64isverygood,butnotgoodenoughforfullIPv4replacement(webandemailwork,butSkypedoesnotwork)IPv6-only+464XLATSolvesIPv4numberingissuebynotassigningIPv4toclientsDecouplesedgegrowthfromIPv4availabilityIPv4-onlyapplicationslikeSkypeworkonanIPv6-onlynetworkbecause464XLATtranslatesIPv4onthephonetoIPv6onthenetwork7IPv6deploymentiseasyachievableT-MobileUSAdidnotspendanyCapExonIPv6Onlyintroduce464XLATonnewphones,sowedonotdisruptanyexistingservicesInnovativethinkinghelpsreducedeploymentcosts(hash128bitnumbersinto32bitfieldsinbillingrecords)IPv6willsavemoneyinyournetwork(lessNAT/CGN,noneedtobuyIPv4addresses,…)8Infact,withroaming,wecanshowChunghwainTaiwanandMYMAXISinMalaysiasupportIPv6todayintheRadioAccessNetwork(RAN)9WhichPlatformsSupports464XLATTodayYESAndroid4.
3+NOBlackberryAppleWindowsPhone()10IMPORTANT!
AnythingthatisnativelyIPv6enableddoesnotrequireanysortoftranslation,464XLATisidleandtransparentforanyIPv6end-to-endflowIPv6end-to-endjustworks!
464XLATisonlyforserviceandapplicationsthatareusingLEGACYIPV4AsmoreandmoreservicestransitiontoIPv6,464XLATisengagedlessandless464XLATisanIPv4EXITSTRATEGY11THETECHNICALDETAILS12464XLATisjustasetofbuildingblocksStatelessNAT64(RFC6145)ClientsidetranslationCLATStatefullNAT64(RFC6146)ProvidersitetranslationPLATDNS64(RFC6147)WhentheFQDNdoesnothaveaAAAArecord,DNS64dynamicallycreatesonethatallowstheclienttouseIPv6andthenetworktranslatesfromIPv6toIPv4attheNAT64Prefix64Discovery(RFC7050)Queriesforthewell-knownFQDNipv4only.
arpa,whichisbydefinitionIPv4-only.
IfthereisaAAAAresponseprovided,thenitisknownthataDNS64isinthepath133Scenariosin464XLAT1.
End-to-endIPv6:Facebook,Google,Wikipedia,Yahoo,Youtube…IPv6->IPv62.
ApplicationsupportsIPv6(webbrowser)buttheserverisonlyIPv4(www.
amazon.
com,www.
myspace.
com,…),soDNS64/NAT64translatesIPv6->IPv43.
ApplicationdoesnotsupportIPv6(Skype,Whatsapp,…),theclientmustprovideastatelessNAT46totheapplicationandstatefulNAT64mustbeinthenetwork:IPv4->IPv6->IPv414HowdoesStatelessNAT64workAlgorithmicallymapIPv4addressestoIPv6addresses,bidirectional,1to1NotdynamicDeterministicMapsallofIPv4's32bitsintoanIPv6/96(orlargerprefix)DefinedinRFC6145Example2001:db8::10.
1.
1.
110.
1.
1.
12001:db8::10.
2.
2.
210.
2.
2.
22001:db8::www.
example.
comipv4www.
example.
com15HowdoesStatefulNAT64work16DynamicallytranslateIPv6packetstoIPv4packetsDynamicNotdeterministic(translationbasedonavailableIPv4pool)Translationstateisshort-livedandbasedonsessioncreationandterminationDefinedinRFC6146ExampleBeforetranslationTCPsource2001:db8:abcd::ffffport555#clientaddressTCPdestination2001:db8:1234::10.
1.
1.
1port80#NAT64addressAftertranslationTCPsource192.
168.
1.
1port555#192.
168.
1.
1availablefromNAT64poolTCPdestination10.
1.
1.
1port80#Last32bitsofIPv6destinationHowdoesDNS64workWhenanFQDNdoesnothaveaAAAArecord,theDNS64willsyntheticallycreateonebasedonanetworkdefinedPref64Thepref64isaprefixhostedontheNAT64fortranslationExamplewithoutDNS64Query=aandaaaaforwww.
example.
comAnswer=a=10.
1.
1.
1,aaaa=NOERRORExamplewithDNS64Query=aandaaaaforwww.
example.
comAnswer=a=10.
1.
1.
1ANDaaaa=2001:db8::10.
1.
1.
117HowisthePref64discoveredontheclientPref64istopologicallylocatedontheNAT64TheDNS64forcesclientstosendtraffictotheNAT64fortranslationfromIPv6toIPv4AutomaticdiscoveryofPref64isdefinedinRFC7050Theclientwilllookupthewell-knownFQDNipv4only.
arpa.
IfaAAAArecordispresentedforthiswell-knowIPv4-onlyFQDN,theclientcanparsetheresponsetofindthePref64usedwithinthisnetwork18Pref64ConfigurationInformationFlow19HowtomakeEVERYTHINGworkonIPv6-only20ZoomOut:Whatdoesthislooklikeinthecontextof3GPPGSM/UMTS/LTE21HighLevelViewofIPv6deployment:Phone,HLRprofile,GGSN,NAT64,IPv6ISP2223ImpacttoNetworkEntitiesImpacttoNetworkEntitiesZoomin:WhatdoesthedefaultAndroidconfigurationlooklike:clatd.
conf24Zoomin:Whatdoesthephoneconfigurationlooklike:APNSettings25InAndroid4.
3,"APNProtocolIPv6"forthe"APNTypedefault"triggerstheuseof464XLATbydefaultIPv6=464XLATTIMEFORWIRESHARK26Likemostthings,westartwithDNSTheclientisIPv6-onlytowardsthenetwork,butthehostOSthinksitisdual-stacksinceithasanIPv4CLATinterfaceandanativeIPv6radiointerfaceSo,theclientdoesaqueryforDNS"A"and"AAAA"recordsTheDNS64respondswithasynthesizedAAAAandtherealAThesynthesizedAAAA=Pref64+realIPv427QuickCheckDoesthesynthesizedAAAAmatchthepref64+realA28pref64RealIPv4Next,theUEselectstheIPv6DNSresponse,andstartsTCPFromtheclientperspective,thisisanativeIPv6end-to-endflowBut,weknowthattheDNSisasynthesizedAAAAandtheclientisactuallysendingitspacketstotheNAT64forIPv6->IPv4statefultranslationThisisjustDNS64/NAT64,noclient-sidetranslationneededforthisscenario29Thefullcaseof464XLATdoubletranslation:WhatsApp30SYNissentfromtheCLATaddress31Remember,wesettheclatd.
conftousetheIIDof::464forCLATtranslationsTheMMSsituationTheAndroidMMSfunctioncommunicatesdirectlytothemodemandby-passesthenormalOSnetworkingstackFrequentlyMMSisitsownAPNThismeans464XLATisbypassed,464XLATonlyworksonthedefaultAPN,notspecialAPNslikeSUPLandMMSSolutionsUseanFQDN,DNS64stillworksfineIfyoucannotuseanFQDN,manuallyuseaNAT64literalinsteadoftheIPv4literal(pref64+ipv4literal)32Security:FollowtheruleofleastprivilegeFilteraccesstotheDNSseverFilteraccesstothePref64ontheNAT64UsingULAPref64willNOTworkwellsinceAndroidprefersIPv4overIPv6ULA.
Thisresultsin100%CLATtranslationsforIPv4resources33SummaryIPv4doesnotfitthebusinessneedstogrowtheedgeofournetworksfueledbygrowthfrominternetofthingsandcloudIPv6workstodayandisdeployedonsomeofthelargestedgenetworks464XLATallowsnetworkstogrowwithoutmanypublicIPv4addressesIPv6deploymentin3GPPGSM/UMTS/LTEisachievabletoday34BigPicture:WemustavoidtheInternet'slargestgrowthengine(mobile)frombeingindefinitelytiedtoscarceIPv4andfragilestatefulNAT44.
Virtono是一家成立于2014年的国外VPS主机商,提供VPS和服务器租用等产品,商家支持PayPal、信用卡、支付宝等国内外付款方式,可选数据中心共7个:罗马尼亚2个,美国3个(圣何塞、达拉斯、迈阿密),英国和德国各1个。目前,商家针对美国圣何塞机房VPS提供75折优惠码,同时,下单后在LET回复订单号还能获得双倍内存的升级。下面以圣何塞为例,分享几款VPS主机配置信息。Cloud VPSC...
如今我们很多朋友做网站都比较多的采用站群模式,但是用站群模式我们很多人都知道要拆分到不同IP段。比如我们会选择不同的服务商,不同的机房,至少和我们每个服务器的IP地址差异化。于是,我们很多朋友会选择美国多IP站群VPS商家的产品。美国站群VPS主机商和我们普通的云服务器、VPS还是有区别的,比如站群服务器的IP分布情况,配置技术难度,以及我们成本是比普通的高,商家选择要靠谱的。我们在选择美国多IP...
对于Megalayer云服务器提供商在之前也有对于他们家的美国服务器和香港服务器进行过评测和介绍,但是对于大部分网友来说需要独立服务器和站群服务器并不是特别的普及,我们很多网友使用较多的还是云服务器或者VPS主机比较多。在前面也有在"Megalayer新增香港VPS主机 1GB内存 50GB SSD 2M带宽 月59元"文章中有介绍到Megalayer商家有新增香港CN2优化VPS主机。那时候看这...
免费dns为你推荐
mediawikiMediaWiki的权限及设置开启javascript怎么在浏览器中启用JavaScript?支付宝蜻蜓发布支付宝蜻蜓f4,可以让没有支付宝的人刷脸付款?搜狗360360浏览器为什么不能让我自动登录了搜狗360电脑自动安装360安全浏览器pintang俏品堂是干什么的?很多论坛都有他们的踪迹。中国保健养猪网猪场基本保健包括哪些方面?什么是seoseo标题和seo关键词是什么意思骑士人才系统问一下嘉缘人才系统和骑士人才系统相比,哪个系统会好点呢?zencart模板zen cart套用模板后,外观控制显示红色打不开,为什么?
cve-2014-6271 256m内存 服务器cpu性能排行 北京双线 卡巴斯基是免费的吗 申请网站 免费ftp 英雄联盟台服官网 php服务器 万网空间 免费网络空间 wordpress空间 此网页包含的内容将不使用安全的https 木马检测 性能测试工具 byebyelove 海尔t68驱动 瓦工工具 阿里云主机 长沙服务器托管 更多