mailbox403forbidden

403forbidden  时间:2021-04-12  阅读:()
NetworkWorkingGroupA.
B.
RoachRequestforComments:3265dynamicsoftCategory:StandardsTrackJune2002Updates:2543SessionInitiationProtocol(SIP)-SpecicEventNoticationStatusofthisMemoThisdocumentspeciesanInternetstandardstrackprotocolfortheInternetcommunity,andrequestsdiscus-sionandsuggestionsforimprovements.
Pleaserefertothecurrenteditionofthe"InternetOfcialProtocolStandards"(STD1)forthestandardizationstateandstatusofthisprotocol.
Distributionofthismemoisunlimited.
CopyrightNoticeCopyright(c)TheInternetSociety(2002).
AllRightsReserved.
AbstractThisdocumentdescribesanextensiontotheSessionInitiationProtocol(SIP).
ThepurposeofthisextensionistoprovideanextensibleframeworkbywhichSIPnodescanrequestnoticationfromremotenodesindicatingthatcertaineventshaveoccurred.
Concreteusesofthemechanismdescribedinthisdocumentmaybestandardizedinthefuture.
NotethattheeventnoticationmechanismsdenedhereinareNOTintendedtobeageneral-purposeinfrastructureforallclassesofeventsubscriptionandnotication.
Contents1Introduction31.
1OverviewofOperation41.
2DocumentationConventions42Denitions53NodeBehavior53.
1DescriptionofSUBSCRIBEBehavior53.
1.
1SubscriptionDuration63.
1.
2IdenticationofSubscribedEventsandEventClasses63.
1.
3AdditionalSUBSCRIBEHeaderValues73.
1.
4SubscriberSUBSCRIBEBehavior73.
1.
5ProxySUBSCRIBEBehavior8RFC3265SIP-SpecicEventNoticationJune20023.
1.
6NotierSUBSCRIBEBehavior83.
2DescriptionofNOTIFYBehavior103.
2.
1IdenticationofReportedEvents,EventClasses,andCurrentState113.
2.
2NotierNOTIFYBehavior113.
2.
3ProxyNOTIFYBehavior123.
2.
4SubscriberNOTIFYBehavior123.
3General143.
3.
1DetectingsupportforSUBSCRIBEandNOTIFY143.
3.
2CANCELrequests143.
3.
3Forking143.
3.
4Dialogcreationandtermination143.
3.
5StateAgentsandNotierMigration153.
3.
6PollingResourceState153.
3.
7Allow-Eventsheaderusage163.
3.
8PINTCompatibility164EventPackages164.
1AppropriatenessofUsage164.
2EventTemplate-packages174.
3AmountofStatetobeConveyed174.
3.
1CompleteStateInformation174.
3.
2StateDeltas184.
4EventPackageResponsibilities184.
4.
1EventPackageName184.
4.
2EventPackageParameters184.
4.
3SUBSCRIBEBodies184.
4.
4SubscriptionDuration194.
4.
5NOTIFYBodies194.
4.
6NotierprocessingofSUBSCRIBErequests194.
4.
7NotiergenerationofNOTIFYrequests194.
4.
8SubscriberprocessingofNOTIFYrequests194.
4.
9Handlingofforkedrequests204.
4.
10Rateofnotications204.
4.
11StateAgents204.
4.
12Examples204.
4.
13UseofURIstoRetrieveState21RoachStandardsTrack[Page2]RFC3265SIP-SpecicEventNoticationJune20025SecurityConsiderations215.
1AccessControl215.
2NotierPrivacyMechanism215.
3Denial-of-Serviceattacks215.
4ReplayAttacks225.
5Man-in-themiddleattacks225.
6Condentiality226IANAConsiderations226.
1RegistrationInformation237RegistrationTemplate237.
1HeaderFieldNames247.
2ResponseCodes248Syntax258.
1NewMethods258.
1.
1SUBSCRIBEmethod268.
1.
2NOTIFYmethod268.
2NewHeaders278.
2.
1Eventheader278.
2.
2Allow-EventsHeader278.
2.
3Subscription-StateHeader278.
3NewResponseCodes288.
3.
1"202Accepted"ResponseCode288.
3.
2"489BadEvent"ResponseCode288.
4AugmentedBNFDenitions289Acknowledgements2910NoticeRegardingIntellectualPropertyRights3011Author'sAddress301IntroductionTheabilitytorequestasynchronousnoticationofeventsprovesusefulinmanytypesofSIPservicesforwhichcooperationbetweenend-nodesisrequired.
ExamplesofsuchservicesincludeautomaticcallbackRoachStandardsTrack[Page3]RFC3265SIP-SpecicEventNoticationJune2002services(basedonterminalstateevents),buddylists(basedonuserpresenceevents),messagewaitingindications(basedonmailboxstatechangeevents),andPSTNandInternetInternetworking(PINT)[1]status(basedoncallstateevents).
Themethodsdescribedinthisdocumentprovideaframeworkbywhichnoticationoftheseeventscanbeordered.
TheeventnoticationmechanismsdenedhereinareNOTintendedtobeageneral-purposeinfrastructureforallclassesofeventsubscriptionandnotication.
Meetingrequirementsforthegeneralproblemsetofsubscriptionandnoticationisfartoocomplexforasingleprotocol.
OurgoalistoprovideaSIP-specicframeworkforeventnoticationwhichisnotsocomplexastobeunusableforsimplefeatures,butwhichisstillexibleenoughtoprovidepowerfulservices.
Note,however,thateventpackagesbasedonthisframeworkmaydenearbitrarilyelaborateruleswhichgovernthesubscriptionandnoticationfortheeventsorclassesofeventstheydescribe.
Thisdocumentdoesnotdescribeanextensionwhichmaybeuseddirectly;itmustbeextendedbyotherdoc-uments(hereinreferredtoas"eventpackages").
Inobject-orienteddesignterminology,itmaybethoughtofasanabstractbaseclasswhichmustbederivedintoaninstantiatableclassbyfurtherextensions.
Guidelinesforcreatingtheseextensionsaredescribedinsection4.
1.
1OverviewofOperationThegeneralconceptisthatentitiesinthenetworkcansubscribetoresourceorcallstateforvariousresourcesorcallsinthenetwork,andthoseentities(orentitiesactingontheirbehalf)cansendnoticationswhenthosestateschange.
Atypicalowofmessageswouldbe:SubscriberNotifier|-----SUBSCRIBE---->|Requeststatesubscription200-Acknowledgesubscription|REFERENCES[RFC3265]Roach,A.
,"SIP-SpecificEventNotification",RFC3265,June2002.
7RegistrationTemplateTo:ietf-sip-events@iana.
orgSubject:RegistrationofnewSIPeventpackageRoachStandardsTrack[Page23]RFC3265SIP-SpecicEventNoticationJune2002PackageName:(Packagenamesmustconformtothesyntaxdescribedinsection\ref{sec:Event}.
)IsthisregistrationforaTemplatePackage:(indicateyesorno)PublishedSpecification(s):(TemplatepackagesrequireapublishedRFC.
Otherpackagesmayreferenceaspecificationwhenappropriate).
Person&emailaddresstocontactforfurtherinformation:7.
1HeaderFieldNamesThisdocumentregistersthreenewheadereldnames,describedelsewhereinthisdocument.
Theseheadersaredenedbythefollowinginformation,whichistobeaddedtotheheadersub-registryunderhttp://www.
iana.
org/aHeaderName:Allow-EventsCompactForm:uHeaderName:Subscription-StateCompactForm:(none)HeaderName:EventCompactForm:o7.
2ResponseCodesThisdocumentregisterstwonewresponsecodes.
Theseresponsecodesaredenedbythefollowinginfor-mation,whichistobeaddedtothemethodandresponse-codesub-registryunderhttp://www.
iana.
org/assignmentResponseCodeNumber:202DefaultReasonPhrase:AcceptedResponseCodeNumber:489DefaultReasonPhrase:BadEventRoachStandardsTrack[Page24]RFC3265SIP-SpecicEventNoticationJune20028SyntaxThissectiondescribesthesyntaxextensionsrequiredforeventnoticationinSIP.
Semanticsaredescribedinsection3.
NotethattheformalsyntaxdenitionsdescribedinthisdocumentareexpressedintheABNFformatusedinSIP[2],andcontainreferencestoelementsdenedtherein.
8.
1NewMethodsThisdocumentdescribestwonewSIPmethods:SUBSCRIBEandNOTIFY.
Thistableexpandsontables2and3inSIP[2].
HeaderWhereSUBNOTAcceptRooAccept2xx--Accept415ooAccept-EncodingRooAccept-Encoding2xx--Accept-Encoding415ooAccept-LanguageRooAccept-Language2xx--Accept-Language415ooAlert-InfoR--Alert-Info180--AllowRooAllow2xxooAllowrooAllow405mmAuthentication-Info2xxooAuthorizationRooCall-IDcmmContactRmmContact1xxooContact2xxmoContact3xxmmContact485ooContent-DispositionooContent-EncodingooContent-LanguageooContent-LengthttContent-Type**CSeqcmmDateooError-Info300-699ooRoachStandardsTrack[Page25]RFC3265SIP-SpecicEventNoticationJune2002Expireso-Expires2xxm-FromcmmIn-Reply-ToR--Max-ForwardsRmmMin-Expires423m-MIME-VersionooOrganizationo-PriorityRo-Proxy-Authenticate407mmProxy-AuthorizationRooProxy-RequireRooRAckR--Record-RouteRooRecord-Route2xx,401,484ooReply-To--RequireooRetry-After404,413,480,486ooRetry-After500,503ooRetry-After600,603ooRouteRccRSeq1xxooServerrooSubjectR--SupportedRooSupported2xxooTimestampooToc(1)mmUnsupported420ooUser-AgentooViacmmWarningR-oWarningrooWWW-Authenticate401mm8.
1.
1SUBSCRIBEmethodSUBSCRIBEisaddedtothedenitionoftheelementMethodintheSIPmessagegrammar.
LikeallSIPmethodnames,theSUBSCRIBEmethodnameiscasesensitive.
TheSUBSCRIBEmethodisusedtorequestasynchronousnoticationofaneventorsetofeventsatalatertime.
8.
1.
2NOTIFYmethodNOTIFYisaddedtothedenitionoftheelementMethodintheSIPmessagegrammar.
RoachStandardsTrack[Page26]RFC3265SIP-SpecicEventNoticationJune2002TheNOTIFYmethodisusedtonotifyaSIPnodethataneventwhichhasbeenrequestedbyanearlierSUBSCRIBEmethodhasoccurred.
Itmayalsoprovidefurtherdetailsabouttheevent.
8.
2NewHeadersThistableexpandsontables2and3inSIP[2],asamendedbythechangesdescribedinsection8.
1.
HeaderfieldwhereproxyACKBYECANINVOPTREGPRASUBNOTAllow-EventsRoo-ooooooAllow-Events2xx-o-ooooooAllow-Events489mmEventRmmSubscription-StateRm8.
2.
1EventheaderEventisaddedtothedenitionoftheelementmessage-headerintheSIPmessagegrammar.
ForthepurposesofmatchingresponsesandNOTIFYmessageswithSUBSCRIBEmessages,theevent-typeportionoftheEventheaderiscomparedbyte-by-byte,andtheidparametertoken(ifpresent)iscom-paredbyte-by-byte.
AnEventheadercontaininganidparameternevermatchesanEventheaderwithoutanidparameter.
Nootherparametersareconsideredwhenperformingacomparison.
Notethattheforgoingtextmeansthat"Event:foo;id=1234"wouldmatch"Event:foo;param=abcd;id=1234",butnot"Event:foo"(iddoesnotmatch)or"Event:Foo;id=1234"(eventportiondoesnotmatch).
Thisdocumentdoesnotdenevaluesforevent-types.
Thesevalueswillbedenedbyindividualeventpackages,andMUSTberegisteredwiththeIANA.
ThereMUSTbeexactlyoneeventtypelistedpereventheader.
Multipleeventspermessagearedisallowed.
8.
2.
2Allow-EventsHeaderAllow-Eventsisaddedtothedenitionoftheelementgeneral-headerintheSIPmessagegrammar.
Itsusageisdescribedinsection3.
3.
7.
8.
2.
3Subscription-StateHeaderSubscription-Stateisaddedtothedenitionoftheelementrequest-headerintheSIPmessagegrammar.
Itsusageisdescribedinsection3.
2.
4.
RoachStandardsTrack[Page27]RFC3265SIP-SpecicEventNoticationJune20028.
3NewResponseCodes8.
3.
1"202Accepted"ResponseCodeThe202responseisaddedtotheSuccessheaderelddenition.
"202Accepted"hasthesamemeaningasthatdenedinHTTP/1.
1[6].
8.
3.
2"489BadEvent"ResponseCodeThe489eventresponseisaddedtotheClient-Errorheaderelddenition.
"489BadEvent"isusedtoindicatethattheserverdidnotunderstandtheeventpackagespeciedinaEventheadereld.
8.
4AugmentedBNFDenitionsTheAugmentedBNFdenitionsforthevariousnewandmodiedsyntaxelementsfollows.
ThenotationisasusedinSIP[2],andanyelementsnotdenedinthissectionareasdenedinSIPandthedocumentstowhichitrefers.
SUBSCRIBEm=%x53.
55.
42.
53.
43.
52.
49.
42.
45;{\SUBSCRIBE}incapsNOTIFYm=%x4E.
4F.
54.
49.
46.
59;{\NOTIFY}incapsextension-method=SUBSCRIBEm/NOTIFYm/tokenEvent=("Event"/"o")HCOLONevent-type*(SEMIevent-param)event-type=event-package*(".
"event-template)event-package=token-nodotevent-template=token-nodottoken-nodot=1*(alphanumevent-param=generic-param/("id"EQUALtoken)Allow-Events=("Allow-Events"/"u")HCOLONevent-type*(COMMAevent-type)Subscription-State="Subscription-State"HCOLONsubstate-value*(SEMIsubexp-params)substate-value="active"/"pending"/"terminated"/extension-substateextension-substate=tokensubexp-params=("reason"EQUALevent-reason-value)/("expires"EQUALdelta-seconds)/("retry-after"EQUALdelta-seconds)/generic-paramevent-reason-value="deactivated"/"probation"RoachStandardsTrack[Page28]RFC3265SIP-SpecicEventNoticationJune2002/"rejected"/"timeout"/"giveup"/"noresource"/event-reason-extensionevent-reason-extension=tokenNormativeReferences[1]S.
PetrackandL.
Conroy,"ThePINTserviceprotocol:ExtensionstoSIPandSDPforIPaccesstotelephonecallservices,"RFC2848,InternetEngineeringTaskForce,June2000.
[2]J.
Rosenberg,H.
Schulzrinne,G.
Camarillo,A.
Johnston,J.
Peterson,R.
Sparks,M.
Handley,andE.
Schooler,"SIP:sessioninitiationprotocol,"RFC3261,InternetEngineeringTaskForce,June2002.
[3]S.
Bradner,"KeywordsforuseinRFCstoindicaterequirementlevels,"RFC2119,InternetEngineeringTaskForce,Mar.
1997.
[4]M.
Day,S.
Aggarwal,G.
Mohr,andJ.
Vincent,"Instantmessaging/presenceprotocolrequirements,"RFC2779,InternetEngineeringTaskForce,Feb.
2000.
[5]T.
NartenandH.
Alvestrand,"GuidelinesforwritinganIANAconsiderationssectioninRFCs,"RFC2434,InternetEngineeringTaskForce,Oct.
1998.
[6]R.
Fielding,J.
Gettys,J.
Mogul,H.
Frystyk,L.
Masinter,P.
Leach,andT.
Berners-Lee,"Hypertexttransferprotocol–HTTP/1.
1,"RFC2616,InternetEngineeringTaskForce,June1999.
InformativeReferences[7]H.
SchulzrinneandJ.
Rosenberg,"Sessioninitiationprotocol(SIP)callerpreferencesandcalleecapa-bilities,"InternetDraft,InternetEngineeringTaskForce,July2002.
Workinprogress.
[8]J.
RosenbergandH.
Schulzrinne,"Guidelinesforauthorsofextensionstothesessioninitiationprotocol(SIP),"InternetDraft,InternetEngineeringTaskForce,June2002.
Workinprogress.
9AcknowledgementsThankstotheparticipantsintheEventsBOFatthe48thIETFmeetinginPittsburgh,aswellasthosewhogaveideasandsuggestionsontheSIPEventsmailinglist.
Inparticular,IwishtothankHenningSchulzrinneofColumbiaUniversityforcomingupwiththenalthree-tieredeventidenticationscheme,SeanOlsonformiscellaneousguidance,JonathanRosenbergforathoroughscrubbingofthe-00draft,andtheauthorsofthe"SIPExtensionsforPresence"documentfortheirinputtoSUBSCRIBEandNOTIFYrequestsemantics.
RoachStandardsTrack[Page29]RFC3265SIP-SpecicEventNoticationJune200210NoticeRegardingIntellectualPropertyRightsTheIETFhasbeennotiedofintellectualpropertyrightsclaimedinregardtosomeorallofthespec-icationcontainedinthisdocument.
Formoreinformation,consulttheonlinelistofclaimedrightsathttp://www.
ietf.
org/ipr.
html11Author'sAddressAdamRoachdynamicsoft5100TennysonParkwaySuite1200Plano,TX75024USAEMail:adam@dynamicsoft.
comVoice:sip:adam@dynamicsoft.
comFullCopyrightStatementCopyright(c)TheInternetSociety(2002).
AllRightsReserved.
Thisdocumentandtranslationsofitmaybecopiedandfurnishedtoothers,andderivativeworksthatcommentonorotherwiseexplainitorassistinitsimplementationmaybeprepared,copied,publishedanddistributed,inwholeorinpart,withoutrestrictionofanykind,providedthattheabovecopyrightnoticeandthisparagraphareincludedonallsuchcopiesandderivativeworks.
However,thisdocumentitselfmaynotbemodiedinanyway,suchasbyremovingthecopyrightnoticeorreferencestotheInternetSocietyorotherInternetorganizations,exceptasneededforthepurposeofdevelopingInternetstandardsinwhichcasetheproceduresforcopyrightsdenedintheInternetStandardsprocessmustbefollowed,orasrequiredtotranslateitintolanguagesotherthanEnglish.
ThelimitedpermissionsgrantedaboveareperpetualandwillnotberevokedbytheInternetSocietyoritssuccessorsorassigns.
Thisdocumentandtheinformationcontainedhereinisprovidedonan"ASIS"basisandTHEINTERNETSOCIETYANDTHEINTERNETENGINEERINGTASKFORCEDISCLAIMSALLWARRANTIES,EXPRESSORIMPLIED,INCLUDINGBUTNOTLIMITEDTOANYWARRANTYTHATTHEUSEOFTHEINFORMATIONHEREINWILLNOTINFRINGEANYRIGHTSORANYIMPLIEDWAR-RANTIESOFMERCHANTABILITYORFITNESSFORAPARTICULARPURPOSE.
AcknowledgementFundingfortheRFCEditorfunctioniscurrentlyprovidedbytheInternetSociety.
RoachStandardsTrack[Page30]

易探云月付18元起,香港/美国/深圳/北京VPS,CN2、BGP等多线路

易探云怎么样?易探云是国内一家云计算服务商家,致力香港服务器、国内外服务器租用及托管等互联网业务,目前主要地区为运作香港BGP、香港CN2、广东、北京、深圳等地区。易探云服务器均选择当下热门线路,比如CN2 GIA、BGP线路、CN2线路等,所有云主机支持月付,并且首月优惠,年付优惠,优惠后香港沙田云服务器/独立ip/香港CN2线路,每月仅18元,188元/年。点击进入:易探云官方网站地址1、香港...

wordpress外贸企业主题 wordpress高级全行业大气外贸主题

wordpress高级全行业大气外贸主题,wordpress通用全行业高级外贸企业在线询单自适应主题建站程序,完善的外贸企业建站功能模块 + 高效通用的后台自定义设置,更实用的移动设备特色功能模块 + 更适于欧美国外用户操作体验 大气简洁的网站风格设计 + 高效优化的网站程序结构,更利于Goolge等SEO搜索优化和站点收录排名。点击进入:wordpress高级全行业大气外贸主题主题价格:¥398...

RAKsmart便宜美国/日本/中国香港VPS主机 低至月$1.99 可安装Windows

RAKsmart 商家这几年还是在做事情的,虽然他们家顺带做的VPS主机并不是主营业务,毕竟当下的基础云服务器竞争过于激烈,他们家主营业务的独立服务器。包括在去年开始有新增多个数据中心独立服务器,包括有10G带宽的不限流量的独立服务器。当然,如果有需要便宜VPS主机的他们家也是有的,比如有最低月付1.99美元的美国VPS主机,而且可选安装Windows系统。这里商家有提供下面六款六月份的活动便宜V...

403forbidden为你推荐
支持ipad支持ipadwordpress模板我在wordpress模板下载了一套模板,做了www.xuanqianbao.com这个站,模板的原站是www.rrzdm.com.一样的模板,我在文件在插入图片,却不能在首页显示,他的网站却可以.直苹果appstore宕机最近app store一直不能用 怎么回事啊 改dns也不能用 持续好久好久了cisco2960配置cisco 2960 配置VLAN上网重庆电信dns重庆电信的DNS是什么加多宝和王老吉王老吉和加多宝的关系?腾讯公司电话腾讯总公司服务热线是多少123456hd有很多App后面都有hd是什么意思dezenderPHP高手来
重庆虚拟空间 江西服务器租用 中文域名交易中心 免费cn域名 圣迭戈 河南服务器 java虚拟主机 灵动鬼影 云全民 创梦 bgp双线 韩国名字大全 jsp空间 工信部icp备案号 国外免费asp空间 电信托管 万网主机管理 独享主机 视频服务器是什么 重庆电信服务器托管 更多